标签云

微信群

扫码加入我们

WeChat QR Code

I've created SSIS package, and now I want to create SQL Agent Job. But when I create and run it, I receive the following error:Which states about version incompatibility. I'm using SQL Sver 2008R2. How can I change its version so that it will be compatible with minimum effort? Interesting, but when I run package in Visual Studio, it runs perfectly. I've tried to download BIDS for 2008R2, but it doesn't open my project made in another version, and I don't want to create it from scratch.


You can't change the version number because the package format is fundamentally different. When they built SSIS 2008 they had no idea what format SSIS 2012 or 2014 would be. Why are you trying to run a 2012/2014 package in SQL 2008? Either upgrade your SQL Server to 2012 / 2014 or redevelop in BIDS

2019年04月22日49分10秒

Basically if you have no good reason to be running SQL Server 2008 then upgrade to SQL Server 2014

2019年04月22日49分10秒