标签云

微信群

扫码加入我们

WeChat QR Code

I know there are tons of Eclipse/Subclipse questions out there regarding issues with javahl. I've been using Eclipse/Subclipse together for a long time without the javahl issues.I'm now running into the same issue though.I just recently upgraded to Java 7:$ java -versionjava version "1.7.0_65"Java(TM) SE Runtime Environment (build 1.7.0_65-b17)Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)I also upgraded to Eclipse Luna 4.4.0 and installed Subclipse. But after creating a remote repository and trying to browse it in the SVN Repository Exploring perspective I see this in the Eclipse .log error log file:java.lang.NoClassDefFoundError: Could not initialize class org.apache.subversion.javahl.SVNClientat org.tigris.subversion.svnclientadapter.javahl.JhlClientAdapter.<init>(JhlClientAdapter.java:57)at org.tigris.subversion.clientadapter.javahl.Activator.getAdapter(Activator.java:64)at org.tigris.subversion.clientadapter.Activator.getClientAdapter(Activator.java:70)at org.tigris.subversion.subclipse.core.SVNClientManager.getAdapter(SVNClientManager.java:127)at org.tigris.subversion.subclipse.core.SVNClientManager.getSVNClient(SVNClientManager.java:94)at org.tigris.subversion.subclipse.core.SVNProviderPlugin.getSVNClient(SVNProviderPlugin.java:462)at org.tigris.subversion.subclipse.core.repo.SVNRepositoryLocation.getSVNClient(SVNRepositoryLocation.java:257)at org.tigris.subversion.subclipse.core.resources.RemoteFolder.getMembers(RemoteFolder.java:164)at org.tigris.subversion.subclipse.core.resources.RemoteFolder.members(RemoteFolder.java:260)at org.tigris.subversion.subclipse.ui.operations.FetchMembersOperation.execute(FetchMembersOperation.java:41)at org.tigris.subversion.subclipse.ui.operations.SVNOperation.run(SVNOperation.java:90)at org.tigris.subversion.subclipse.ui.repository.model.SVNRepositoryRootElement.fetchDeferredChildren(SVNRepositoryRootElement.java:73)at org.eclipse.ui.progress.DeferredTreeContentManager$1.run(DeferredTreeContentManager.java:238)at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)See pic below to see the components I installed with Subclipse:Regarding the SVNKit Client Adapter (Not required), I have installed Subclipse both with and without this component selected and in both cases I see the same javahl.SVNClient error.How do I solve this?As an aside, I figured maybe I'd give Subversive a go. Subversive is not available in the Eclipse 4.4 udpates software site (http://download.eclipse.org/eclipse/updates/4.4) so I tried the Eclipse Marketplace Client. Installing via Marketplace I get the following error:The following solutions are not available: Subversive: SVN Team Provider 2.0Does anyone have Eclipse and Subclipse or Subversive working? What steps do I need to take to get this working?UPDATE attached is a screenshot of the empty SVN interface client dropdown.Thanks!


I have successfully installed subversive with eclipse Luna. See my answer(steps) below and let me know if u need anything else.

2019年09月18日58分37秒

still had the svn from last eclipse major. update to luna svn did the trick for me! thx.

2019年09月18日58分37秒

Just FYI I'm using Mac OS X 10.7.5. Check my screenshot. I did install SVNKit. But when I go to change to SVN Kit, under 'SVN interface -> Client' There is a dropdown select list, but its empty. Nothing to select or change to.

2019年09月19日58分37秒

I also am having trouble with Eclipse Luna. I didn't do a clean install, I just tried updating from Kepler. It had to fix a bunch of dependencies to go through the process, some of which had to do with Subversion. Now SVN isn't working for me, I get an empty drop-down for SVN Connectors.

2019年09月18日58分37秒

Thanks for the ideas. I've updated the original question with a screenshot of Eclipse SVN preferences where you can see the empty SVN interface client list is an empty dropdown. It's odd. This is a completely fresh install of Luna, I'm surprised I'm seeing issues already. Normally after installing several plugins and lots of use, crashes, etc...I might start seeing problems, but after a clean install this is strange.

2019年09月18日58分37秒

The problems are all consistent with one or more of the plugins failing to load. I'd just keep digging into the Eclipse logs to see what you can spot. The fact that you do not even see items on the drop-down points to a very low-level problem where the code is just not loading at all.

2019年09月18日58分37秒

Yeah...I couldn't find it. Figured a clean reinstall would be quicker which is what I did. Things are working now. Don't know what went wrong. Thanks!

2019年09月18日58分37秒

The question was about Subclipse, not Subversive - two different projects trying to do a similar thing.

2019年09月18日58分37秒