标签云

微信群

扫码加入我们

WeChat QR Code

I am facing a strange problem, where my eclipse.exe force closes (it disappears! no process on task manager), when i do synchronization with the SVN repository.Here is the background,Today morning I tried to do "Update to HEAD" operation on my local copy (from the SVN repository). During this, the Update operation failed saying (Update failed, Internal error 68)After this, whenever i try to sync my local copy with the SVN repository, after a while my eclipse.exe process is getting killed abruptly.Eclipse Version - Eclipse Java EE IDE for Web Developers.Version: Indigo Service Release 1 Build id: 20110916-0149Subversion plugin infoSubclipse (Required)1.8.4Subclipse Integration for Mylyn 3.x 3.0.0 Subversion Client Adapter 1.8.0Subversion JavaHL Native Library Adapter 1.7.2Subversion Revision Graph 1.1.1 I checked Eclipse installation folder and see the hs_err_pid*log file being created, which has following stack trace.Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)jorg.apache.subversion.javahl.SVNClient.status(Ljava/lang/String;Lorg/apache/subversion/javahl/types/Depth;ZZZZLjava/util/Collection;Lorg/apache/subversion/javahl/callback/StatusCallback;)V+0jorg.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getStatus(Ljava/io/File;ZZZZLorg/tigris/subversion/svnclientadapter/ISVNStatusCallback;)[Lorg/tigris/subversion/svnclientadapter/ISVNStatus;+135jorg.tigris.subversion.subclipse.core.client.StatusCommand.execute(Lorg/tigris/subversion/svnclientadapter/ISVNClientAdapter;Lorg/eclipse/core/runtime/IProgressMonitor;)V+67jorg.tigris.subversion.subclipse.core.client.StatusAndInfoCommand.execute(Lorg/tigris/subversion/svnclientadapter/ISVNClientAdapter;Lorg/eclipse/core/runtime/IProgressMonitor;)V+3jorg.tigris.subversion.subclipse.core.client.StatusAndInfoCommand.run(Lorg/eclipse/core/runtime/IProgressMonitor;)V+12jorg.tigris.subversion.subclipse.core.sync.SVNWorkspaceSubscriber.findChanges(Lorg/eclipse/core/resources/IResource;ILorg/eclipse/core/runtime/IProgressMonitor;)[Lorg/eclipse/core/resources/IResource;+95jorg.tigris.subversion.subclipse.core.sync.SVNWorkspaceSubscriber.refresh(Lorg/eclipse/core/resources/IResource;ILorg/eclipse/core/runtime/IProgressMonitor;)Lorg/eclipse/core/runtime/IStatus;+43jorg.tigris.subversion.subclipse.core.sync.SVNWorkspaceSubscriber.refresh([Lorg/eclipse/core/resources/IResource;ILorg/eclipse/core/runtime/IProgressMonitor;)V+91jorg.eclipse.team.internal.ui.synchronize.RefreshSubscriberParticipantJob.doRefresh(Lorg/eclipse/team/internal/ui/synchronize/RefreshParticipantJob$IChangeDescription;Lorg/eclipse/core/runtime/IProgressMonitor;)V+24jorg.eclipse.team.internal.ui.synchronize.RefreshParticipantJob.run(Lorg/eclipse/core/runtime/IProgressMonitor;)Lorg/eclipse/core/runtime/IStatus;+183jorg.eclipse.core.internal.jobs.Worker.run()V+31v~StubRoutines::call_stubThanks in advance for your time and effort for this thread.


Could you try downloading a separate client and updating the repository inside that? It may either fix the problem or give a more descriptive error message.

2019年09月18日58分57秒

Thanks for your reply. I even tried that. I tried updating the repository with Tortoise SVN and then came back to eclipse to sync it. Even this did not work. Finally i did a fresh checkout of the project and now the error seems to be resolved.

2019年09月18日58分57秒