I tried installing subclipsethrough the "Help->Install New Software" and the URL is http://subclipse.tigris.org/update_1.8.x but it fails every time. It shows following items===================================CollabNet Merge Client 3.0.8 Subclipse (Required) 1.8.8 Subversion Integration for Mylyn 3.x (Optional) 3.0.0 Subversion Client Adapter (required) 1.8.2Subversion JavaHL 126.96.36.199Subversion Revision Graph===================================I tried them one by one and only the following could be installed, other four failed:Subversion Client Adapter (required) 1.8.2Subversion JavaHL 188.8.131.52One of the errors I get is:An error occurred while collecting items to be installedsession context was:(profile=epp.package.php, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).Comparison method violates its general contract! ================================================My environment is as follows:OS: Windows 7 64 BitEclipse PDT All in one from http://www.zend.com/en/downloads/thankyou?package=468Subclipse update_1.8.xIs there anything I'm doing wrong?I need at least Subclipse 1.8.8 and CollabNet Merge Client 3.0.8 also in addition to Subversion Client Adapter 1.8.2, Subversion JavaHL 184.108.40.206 that I could install.Thanks
That link pointed me at the right answer which was forcing the vm to the 1.6 JRE... eclipse -vm "C:\Program Files\Java\jre6\bin\javaw.exe"
I noticed the formatting was bad, I've updated the question, please check again. I could install Subversion Client Adapter 1.8.2, Subversion JavaHL 220.127.116.11 but not the Subclipse 1.8.8 I need this one also at least.
It looks like a problem in the Eclipse p2 configuration locally.Does not seem to have anything to do with what you are installing.
I checked my control panel and I see 3 entries there: Java 6 update 31,Java 7 Update 3,Java 7 Update 3 (64-bit)Is this the issue that I'm having multiple of them?
I do not believe this would be related to the Java version.Eclipse maintains a bunch of metadata about what you have installed.It looks like that metadata has some problems.It seems to happen a lot.
Have you tried to see if you can install other Eclipse plugins?My guess is that trying to install other plugins would show the same error.